1
Vote

No working tutorials

description

Hello,
I am using Visual studio 2013 Update 5 and the latest templates from Nuget 1.9.0.
I have tried to make a default implementation to work, using the AdventureWorks2012 Database.

I had problems with a Spatial Type in address table, in this model. Just to move ahead I removed the field with Geographic data.

Next think was just to get a list of the employees from the test console application.
The T4 templates seem to comment the configuration entries for the WCF service. Removing them i always get an exception, that can't resolve this entry in config file.
__<client>
        <endpoint address="http://localhost/Uni.MyProject.Server.Host/AdventureWorks2012DataService.svc" binding="wsHttpBinding" bindingConfiguration="WSHttpBinding_DataService" 
                  contract="Uni.MyProject.Common.Domain.Service.Contracts.IAdventureWorks2012DataService" name="AdventureWorksDataService"/>
     </client>
__

Any suggestions about that, I would really like to evaluate n-Tier Entity Framework.
Thanks

comments

ChristofSenn wrote Dec 27, 2016 at 11:19 AM

  1. Make sure your entpoint name matches expectation (e.g. AdventureWorksDataContext --> endpointConfigurationName="AdventureWorksDataService") or specify the name explicitely via constructor parameter to your client data context.
  2. Make sure client (app.config) and server (web.config) wcf configurations match
  3. Make sure endpoint address in client configuration match actual server address (pay attention to tcp port when debugging)